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Chapter 1. Introduction
Arbil is an application for arranging research material and associated metadata into a format appropriate
for archiving.

Arbil is designed so that it can be used off-line in a remote location. The data can be entered at any stage
in part or as a whole. When an internet connection is available the work can then be transferred to the main
archive via Lamus.

1.1. General Information
Two steps are required in adding a corpus to the MPI Archive. The first involves creating the corpus, editing
the metadata and converting it into an archivable format using ARBIL(Archive Builder) while the second
involves exporting the created/edited corpus to the archive using LAMUS .

This manual describes in detail the first step, i.e. Arbil. For the second step, Lamus, please refer to the
LAMUS manual [http://tla.mpi.nl/tools/tla-tools/lamus]).

Arbil allows you to view all the corpora in the archive or any other remote location (provided you have
access rights).

Corpora from the archive can also be edited through Arbil. If the changes are to be implemented they have
to go through Lamus.

In short, Arbil allows you to:

1) view the archive;

2) import metadata from the archive and edit them;

3) create new corpora, with new metadata and media files;

4) export the IMDI files, which are then ready to be archived.

Changes you make to corpora imported from the archive will not affect the archive directly, as Arbil merely
allows you to make changes on a local level, and not to the archive itself. If you want to upload your changes
to the archive, you must export them to LAMUS, which in turn, allows you to submit corpora into the archive.

Arbil is the next generation of the IMDI Editor with a more powerful user interface and functionality. This
manual contains detailed information on how to use Arbil: how to create new corpus structures/session
nodes, and how to modify existing corpora. It does not explain the internal structure of IMDI, though. For
more information on the IMDI metadata set, please refer to the following link: http://tla.mpi.nl/tools/tla-
tools/imdi_browser/.

For a less detailed description of the application, please refer to the Arbil User Guide [http://www.mpi.nl/
corpus/html/arbil-imdi_ug/index.html].

You can access all the information present in this manual from the application itself, using the Help Menu.

We encourage you to provide feedback, comments, and suggestions, so that we can improve the
documentation in order to better meet your needs. Also, in case of problems that are not addressed anywhere
in this guide, please use the Arbil Forum [http://tla.mpi.nl/forums/software/arbil/].

1.2. Overview
The way you start working on your data is twofold. You can:

a) either create a new corpus;

b) or make a copy of an already existing corpus or of its branch from the server and edit it.

http://tla.mpi.nl/tools/tla-tools/lamus
http://tla.mpi.nl/tools/tla-tools/lamus
http://tla.mpi.nl/tools/tla-tools/imdi_browser/
http://tla.mpi.nl/tools/tla-tools/imdi_browser/
http://www.mpi.nl/corpus/html/arbil-imdi_ug/index.html
http://www.mpi.nl/corpus/html/arbil-imdi_ug/index.html
http://www.mpi.nl/corpus/html/arbil-imdi_ug/index.html
http://tla.mpi.nl/forums/software/arbil/
http://tla.mpi.nl/forums/software/arbil/
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Either way, the files you create/edit will be saved on your computer (in the so called Local Corpus). This
enables you to work off-line in a remote location while still in the field. Changes you make in Arbil will
not affect the archive.

Arbil consists of 6 working areas as shown in the figure below:

1) the Menu Bar, which allows you to access the main commands;

2) the Remote Corpus, which contains locations from the Language Archive. Here is where you can see
the corpora and choose the ones you wish to import;

3) the Local Corpus, which contains the user's main working area. Here is where corpora from the Remote
Corpus can be imported and edited. It is also used for creating new corpora;

4) the Files /Favourites (Working Directories). Here is where you can link directories from your computer
to Arbil in order to import media files and create favourite metadata items. It is useful for quickly accessing
frequently used item;

5) the Preview Area, which shows metadata of the selected node (in the figure below, it displays the details
for "New Corpus"). It changes every time a new node is selected;

6) the Table Area, which is where several nodes can be opened, compared, and modified at the same time
(in the figure below, the three nodes from the Local Corpus are placed in a table in this area).

Note

You can customize the size of these panels. To make a window larger or smaller place the
pointer on the border and drag it in the direction in which you want the window to expand or
contract. It is also possible to hide the preview area by unchecking the option Show Selection
Preview from the View menu.

Figure 1.1. Arbil workspace
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1.3. Workflow
When working with Arbil, you have to decide whether you are going to work on an existing corpus from the
Remote Corpus or create a new corpus. Assuming that you intend to edit metadata in the archive and add
additional media files, you will have to follow the steps 1-6 below.

The Arbil workflow for editing a corpus is as follows:

1) Browse the Remote Corpus and select the corpus which you intend to edit; drag it from the Remote Corpus
panel into the Local Corpus panel so as to import it.

2) Now that the corpus is located in the Local Corpus, you may edit it freely. To edit the metadata, drag the
node into the Table Area (marked with number 6 in figure 1.1 ) and edit the fields accordingly (editing can
also be done in an external editor). This can be done with several corpora/sessions at once.

3) In order to add resources to sessions (e.g. media files and annotations), you must set up a working directory
which links a folder on your computer to Arbil. This means that any media files in this folder will appear
in the Working directory area so that resource files can be added to the sessions of a corpus in your Local
Corpus. To add files to your new corpus, drag and drop them from the tab Files to the Local Corpus. Now
you can edit the metadata following step 2 above.

4) Stored session elements, such as common actors, can be added to the local corpus via the right click
optionAdd from favorites.

5) Once your metadata have been edited correctly and your desired media files have been added to your
sessions, you can export the metadata files to a directory (folder) on your computer.

In order to create a new node, add a node in the Local Corpus and follow the same steps.

Note: This is as far as you can get using Arbil.

6) Once the work is finished, Open Lamus [http://tla.mpi.nl/tools/tla-tools/lamus] and import the directory
(folder) which contains the corpora. It is crucial to note that instead of uploading single files you can make
use of the potential of Arbil and upload entire directories including all linkages among the individual files
contained. Via Lamus, your work can then be uploaded to the archive.

Corpus and session nodes are easily edited directly in Arbil (see chapter 4 and chapter 5) but they can also
be worked on in an external editor, such as Microsoft Excel or another spreadsheet program (see 7.3).

Figure 1.2. Arbil Work flow

http://tla.mpi.nl/tools/tla-tools/lamus
http://tla.mpi.nl/tools/tla-tools/lamus
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In Arbil all work on corpora and sessions takes place in the Local Corpus tree. The various import, export,
and edit operations, displayed in the figure above, can usually be triggered by right-clicking on elements in
the Local Corpus, or via "drag and drop" (e.g.. clicking on an element in the Remote Corpus, holding the
mouse key and dragging the element to the Local Corpus, or to a corpus node within the Local Corpus).
Media files (i. e. audio and video recordings) and written resources can also be added to sessions via "drag
and drop" from the Working Directories tree in the Files tab. Only for importing previously exported sessions
to the local corpus root one has to access the File menu in Arbil's menu bar.

1.4. Arbil icons
The following table defines graphical icons used by Abril:

 Top node of the Remote Corpus tree (read only)

 Top node of the Local Corpus tree (it contains local files)

 Top node of the Working Directories tree (short cuts of files in the Local Corpus)

 The file is in the Local Corpus (local file)

 The file is on the remote server (read only)

 The file is located in the local corpus but has been imported from the remote server

 Corpus node

 Catalogue

 IMDI session

 Closed node (sub-components are folded)

 Open node (direct sub-components are displayed)

 IMDI node that contains data

 Resource without specified resource link

  IMDI node with no data and the number of subnodes indicated

 Node has optional fields but contains no data

 Written resource

 Video resource
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 Audio resource

Image resource

 Resource is locked and can only be opened by users with access rights

 Resource is unlocked for the user

Info file

 In resources: archivable file of an unknown type

 File that is not an archivable format and therefore cannot be added as a resource

 The node has been added to the list of the favourites and can be duplicated via the favourites add menu

 Node is currently being loaded

 File not found

 Cosed controlled vocabulary

 Closed multiple vocabulary. Enter multiple values by inserting a comma (,) between separate entries.

 Open controlled vocabulary (text can be selected from a list but new text can also be added)

 Open multiple vocabulary by inserting a comma (,) between separate entries

 Language selection on field (e.g. Description language)
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Chapter 2. Starting Arbil
When you open Arbil for the first time the wizard will appear and give you the possibility to configure Arbil
to your needs. The first window is a welcome window. Press Next to move to the second step of the wizard.
In this window, you select the metadata format i.e. IMDI or CMDI; you can choose one or both of them. In
this manual we will assume that IMDI is used but the instructions apply equivalently to CMDI . The third
window enables you to choose the corpora that will appear in the Remote Corpus box. If you know the

URL1 of a corpus that you will be working on frequently, you can add it to this list so that it will be available
on the root level of the tree in the Remote corpus box. After finishing with Remote locations press Next and
then the Finish button. You can reopen the wizard through the Help menu by choosing Run setup wizard.

Figure 2.1. Welcome to Arbil

Figure 2.2. Remote locations

Arbil can be started in two ways, either via the webstart or by downloading the installer (see here [http://
tla.mpi.nl/tools/tla-tools/arbil]). Note that the webstart does not work for Ubuntu; in this case you will have
to download the installer version.

2.1. Language selection
Arbil 2.5 allows you to change the language in which the application will open and work. At the moment,
you can choose among: English (either the United Kingdom or the United States variants), German, Italian
and Spanish.

When you start the application for the first time, a dialog window will come out asking you to choose a
language. After having chosen and selected OK, Arbil wizard will open in the language you have selected
(see figures below).

However, you can always change the language via the option Select language in the Help menu, which will
open the same dialog window as before.

You can copy the URL of a corpus by selecting the node in the remote tree in Arbil when the wizard is not showing, right click and select
'Copy'; or get it from the IMDI browser by navigating to the corpus, right click the node and select 'Create bookmark' and copy the URL link.
Then you can paste it into the box in the wizard.

http://tla.mpi.nl/tools/tla-tools/arbil
http://tla.mpi.nl/tools/tla-tools/arbil
http://tla.mpi.nl/tools/tla-tools/arbil
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Figure 2.3. Language selection

Figure 2.4. Arbil wizard
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Chapter 3. Set-up

3.1. Corpus nodes, sessions and catalogues
It is important to understand the distinction between the following elements, as they are essential to the
internal structure of Arbil:

corpus node 

corpus session 

corpus catalogue 

IMDI is organized hierarchically, meaning that any number of other corpus nodes can fall under each corpus

node  . These nodes do not describe resources but are meant to construct the corpus structure only. It

is the session nodes  that include information about the actors, content, media file, project, source and
written resources.

A corpus catalogue , on the other hand, is a general descriptive element of the whole corpus.

Note

If, once you have set up your Arbil page, you realize that the font size is either too small or
too big, you can resize it as you like it via the options included in the View menu, i.e.: Larger
font; Smaller font; Reset font size.

3.2. Remote Corpus
The Remote Corpus contains all the corpora located in the archive. Currently it is not possible to add anything
to the remote corpus or edit it in general. It is primarily used to view data, but it also allows you to import
corpora to the Local corpus (see Section 3.3), where they can then be modified.

It has a tree-like structure in which each node contains multiple sub-branches. To open any of them, click
on the bullet on the left of the node representing the branch or double click the node itself. This can be
repeated for the sub-branches as well. In this way you can view the whole structure of the corpus. If you
click the bullet again, the node will fold back (the Remote Corpus is very similar in use to the web-based
IMDI browser [http://corpus1.mpi.nl/]).

3.2.1. Adding and removing Remote Locations

If you want to use a corpus that is not available under remote corpus, or want to link it at root level, you can
add it yourself, provided that you know the URL address of the corpus. Right click on the Remote Corpus
top node and choose Add Remote Location. In the pop-up window enter the URL and press OK. The corpus
should now appear in the main list of the Remote Corpus window.

http://corpus1.mpi.nl/
http://corpus1.mpi.nl/
http://corpus1.mpi.nl/
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Figure 3.1. Adding a remote location

Since you might not want to use all of the corpora in the Remote Corpus, it is also possible to remove any
of the locations of the Remote Corpus at the root level so as to only display the corpora that you need. This
can be done at the root level only (see figure 3.1) by right clicking on the node (e.g. for MPI corpora) and
selecting Remove Remote Location.

If you have removed some corpora, it is always possible to re-add them to the Remote Corpus by right
clicking on it (the remote corpus) and selecting Add Default Remote Locations.

To add a subnode to the root level browse to the desired sub corpus, right click on it and choose Copy. Then
go back to the top node of the Remote Corpus, right click on it, choose Add Remote Location and paste
the URL in the dialogue box. The sub corpus will now appear in the Remote Corpus tree.

The corpus data on the Remote Corpus are frequently updated by researchers. To be sure that you are working
with the newest version of the available data, you can update it manually on the nodes that you believe have
been altered. To do this, right click on the specific corpus/session you want to update and select Reload.
In principle, after new data has been entered into the archive, it can take up to an hour before the archive
is updated.

3.2.2. Add to Tree Root

It may happen that the branch you want to work on is located at a very low hierarchical position in your
remote corpus. To avoid clicking on every single node in order to get to the one you need, you can select
this one, right click on it, and select the option Add to Tree Root. A copy of it will be created and placed at
the end of the Remote Corpus tree, so that you will not have to look for it anymore (see kleve-route example
in the figure below).
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Figure 3.2. Add to Tree Root

3.2.3. Viewing Remote Corpus Information

In general, the easiest way to view the information of a node is to drag and drop it from the remote corpus
into the grey working area on the bottom right. It is also possible to right click on the selected node and
choose View Selected. In either case, a window pops up with the desired information listed in tables. This
can also enable you to view multiple nodes at the same time.

To open multiple nodes at the same time, simply hold Ctrl while clicking on the desired nodes. Then drag
them to the working area (or right click and select View selected). You will get a similar scenario to this
displayed in the figure 3.2 below.

Note

If you have an existing open table, it is also possible to add additional tree nodes of any form
(i.e. sessions, corpora and files). Simply drag any unselected node from the tree structure and
drop it on the table. It will be automatically added to the table as a row.
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Figure 3.3. Viewing multiple selected corpora

There are also two other quick ways for viewing corpus/session information.

(1) Let your cursor rest above a corpus or session node without clicking. Information about the corpus/session
will be displayed in the tooltip under the cursor.

(2) Click on a corpus/session node. Information will be shown up in the top right frame.

When viewing information on multiple corpora, each row corresponds to one corpus, while each column
corresponds to one metadata element (data category). By clicking on any of the column names, you can
easily sort rows alphabetically within a given table.

In a table that includes several different types of nodes (such as sessions and corpus nodes as listed in the
table below) notice that not all the elements of the corpus structure are described in terms of the same data
categories (column); for example, there are data categories that belong to a session but not to a corpus node.
Such data fields are marked in grey and are not available. This is also the case in the Local corpus (Section
3.3).

Figure 3.4. Not editable cells in a table

In some cases you will see that instead of a value in a cell in the table there is a caption: <multiple values>.
This means that there is more than one value for this data category for this particular node. To see these
values click on <multiple values> and a new window will pop up with the information shown.

3.3. Local Corpus
The Local Corpus  is located beneath the Remote Corpus panel in the Arbil left frame. Remember that the
Local Corpus is the main working area and that changes made in the Local Corpus will not affect the archive.
The Local Corpus serves two main functions: 1) editing existing corpora, 2) creating new corpora. Section
3.3.1 below explains how local corpora may be modified by (re)editing the data from the Remote Corpus.
Section 3.3.2 explains how to create and subsequently modify new corpora, session nodes or resource files.

3.3.1. Import to Local Corpus
If you have decided to work on a corpus from the archive you first need to import it from the Remote Corpus
to your Local Corpus, and then you can edit it. To do so, select the node/session from the Remote Corpus
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and simply drag the item and drop it into the local corpus icon . You can also right click on the corpus
node you want to import and choose Import to Local Corpus.

In the dialogue box that pops up you may want to check the option Import Resource Files (if available),
through which, as the name itself says, both the node and the possible resources that such node contains
will be imported into the Local Corpus. Please be aware that: 1) Arbil cannot deal with resources that need
authentication; 2) copying the resource files may take some time and will use disk space on your computer.

Select Start to initiate the import process. Select Stop if you want to interrupt such process.

Figure 3.5. Import Resource Files

Once the import process has started a message can appear, asking you whether you want to overwrite an
existing local corpus/session node from the same original location. When is this option useful? Consider
the likely scenario that you have imported a node from the Remote corpus and started editing it. If you
want to reset the changes, you can reimport it from the Remote Corpus and answer "Yes" to the question
"Overwrite?". You can apply this option to every branch of the corpora.

You may want to check the option Remember my choice, so that the message will not come out again for
the other already existing files that Arbil will encounter during the import process.

Figure 3.6. Overwrite local changes

Once the import has finished you will see a window telling you how many Metadata Files have been
processed. If you select Details, you will see all the possible errors that have occurred during the process.
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Figure 3.7. Import completed

In the case that you have uploaded a corpus from your local corpus to the Remote Corpus and you want to
edit it again, editing should not be done in the already existing file in your Local Corpus. In this case you
have to reimport the corpus from the Remote Corpus where your uploaded it before via Lamus.

3.3.2. Creating corpus and session nodes
Instead of copying an existing corpus or corpus nodes from the Remote Corpus, you can also create your
own corpus or add session nodes in the local corpus. Moreover, you can also add a catalogue, in which the
general information about your corpus will be stored.

To do so, select the top node of the Local Corpus (corpus node), right click it and select the option Add >
Catalogue; Add > Corpus or Add > Session. See Chapter 4 for more information.

3.3.3. Local Corpus Storage Directory
When Arbil is started for the first time a .arbil directory should be automatically created on your local
machine. In it, and more specifically into a subfolder named ArbilWorkingFiles, the content of your Local
Corpus should be located and saved. However, the location of your Local Corpus can always be changed.
To do so, go to Options > Local Corpus Storage Directory > Move Local Corpus Storage Directory....

Note

It may happen that Arbil detects multiple storage directories on your machine (which may be
due to an older version of the application conflicting with a new one). In those cases you will
be notified through a warning message, asking you what you are going to do with such storage
directories.

3.4. Working Directories
Beneath the Local Corpus window, you will find two different tabs: Files and Favourites. This section
describes the Files tab and the functioning of its Working Directories, while Section 3.5 below focuses
on the Favourites tab.
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The Files tab is responsible for linking a folder from your computer to Arbil so that media files can be
transferred into your corpus. It is advisable to have one or more folders on your computer that contains all
the necessary files that you would like to upload to your corpus. This way, you can simply link this folder
and retrieve all the necessary files.

The option Files is selected by default. Its Working Directories are meant to keep at hand the resources
that you want to add to your corpus (such as annotations, audio files, pictures etc.). To add a new Working
Directory, right click on the Working Directory node and select Add Working Directory. Now browse to
the directory you want to add, select it and click again on Add Working Directory. In the figure 3.8, the
directory "Recursion pics" is about to be added to the Working directories, after which you will be able to
access the media files present in this folder.

Figure 3.8. Add working directories

After linking a directory to Arbil, you will have access to the folder. To import the media files (e.g.
Droste.jpg) to a session of a corpus, simply drag and drop them into the desired session.

Figure 3.9. Linked folder

Note

If you right click on Working Directories, you will also see that it is possible for Arbil to show
you all hidden files (option Show hidden files). This option is useful when you want to include
corpus files which are normally hidden in your file manager.
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Browsing through the Working Directories is very similar to browsing through the Remote or the Local
Corpus. To open/close a folder click on the bullet on the left of its name or double click on the name itself.
If you have added or modified the content of a directory outside Arbil, you can update such content by right
clicking Working Directories and selecting Reload.

If you want to view the file information you can follow the instructions described in Section 3.2.2. (Viewing
Remote Corpus Information). Remember that if you place the cursor over a file, an information window will
appear that will give you a file description, including the information about whether the file is archivable or
not. Archivable files can be uploaded to the server. Image 3.7 shows an example of an archivable file:

Figure 3.10. Archivable file

Editable files from the Working Directory can also be opened by external applications. Right click a given
file (e.g. audio file, picture) and select Open in External Application.

If the file is not archivable, the  icon will appear. If you hold the mouse pointer on the file, you will see
the following information:

Figure 3.11. Unarchivable file

For the list of accepted file types and formats, check the LAMUS manual [http://www.mpi.nl/corpus/html/
lamus/apa.html].

A file that is not supported by Arbil can be kept in Arbil anyway and still be added to a Session in the Local
Corpus, thus overriding the decision of the internal type checker. To do so, right click on the unarchivable
file and select Override Type Checker Decision; a pop up window will appear asking you to say whether
the file is a MediaFile or a WrittenResource; the  will then change into an icon of either a media file or
a written resource file, and you will be able to add it as a resource file into the Local Corpus. To open the
file right click it again and select Open in External Application. Beware that overriding the type checker
decision can cause your corpus not to be accepted into the archive (rejected by Lamus).

In addition, if you have modified your uploaded file externally, you may want to check whether it is still
accepted by Arbil. To do so, right click the file in Working Directories and select Force Type Checking.
If something has happened to your file you will see its icon change.

3.5. Favourites
The tab Favourites is meant for storing session elements that you would like to re-use in new sessions, such
as actors, language elements, locations etc. Elements that can be saved in Favourites are: IMDI sessions

( ), actors, content elements, etc. When taken to the favorites tab, such elements are placed in their
corresponding subcategories; i.e. if you drag an actor, this will be automatically located under the category
"Actor". If you have a number of elements in your Favourite List and you are not certain what the content
of a given element is, you can always place the cursor over it and wait for the tool tip (information window)
to appear (see figure below).

http://www.mpi.nl/corpus/html/lamus/apa.html
http://www.mpi.nl/corpus/html/lamus/apa.html
http://www.mpi.nl/corpus/html/lamus/apa.html
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Figure 3.12. Favourites List

In order to add an element from the local corpus to the Favourites List, right click its node and choose Add
to Favourites List. The element will appear in the Favourites List. You can also just drag and drop it from
the corpus tree structure, right down to the Favourites List. If this element is needed again, you can place it
into a preferable location in your Local Corpus either by dragging and dropping it from the Favourites list
or by copying and pasting it in one of the Local Corpus (sub)branches.

Figure 3.13. Adding to favourites via menu

Once you have completed your Favourites list, you can start using it. Let's say you want to add a particular
Actor to a session in your Local Corpus: in order to do so choose the session in question, right click it, select
Add from Favourites and click on the desired actor. Otherwise, you can simply drag and drop the actor
from the Favorites tab to session in the Local Corpus.

Figure 3.14. Adding favourites to a Session
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Note that the items in the Favourite List can be viewed and edited in the same way as the elements of the
Local Corpus (i.e. via the options of the right click context menu). This means that if you make changes
to your favourites you will have to right click on them and select Save Changes to Disk to make them
permanent (or use Ctrl/cmd+S). The favourites which have been edited turn blue, which indicates that they
contain pending changes to be saved locally.

Favorites can also be exported and/or (re)imported. In order to export your favorites: right click on Favorites
(in the Favorites tab) and select Import/Export Favorites. A window like the one in the figure below will
appear. Select the favorites you want to export, then Export selection, and after having chosen the location
where to export select Save. As soon as the export process is complete you will see a message confirming
it and the folder containing the exported files will open.

Figure 3.15. Export/Import Favourites

As you can see from the image above, if you want to import some favorites into Arbil you have to follow
the same instructions as the ones explained for the export: right clich on favorites > select Import/Export
Favorites. This time, though, choose Import from dick. Choose the (.config) file that you want to import
and select Open. You will see a message confirming the successful import, while in the Favorites tab you
will see the just imported files.
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Chapter 4. Editing the corpus
structure

This chapter focuses on how to develop the structure of the Local Corpus.

4.1. Adding a new corpus node
Once you have created/imported a corpus, you can add new corpus branches to any corpus node of the Local
Corpus. To do so, right click on a corpus node and select Add > Corpus. A new corpus (called by default
Standard Corpus) will be created in the tree structure directly under the node you clicked on. At the same
time also a table will pop up in the table area, in which you can edit the metadata of the new corpus node
(e.g. corpus name, title, description, language etc.).

Figure 4.1. Adding a new corpus branch

4.2. Adding a new session node
In addition, a new session node can be added to each corpus node. Right click on a corpus node and select
Add > Session (figure 4.2). A new session will be created in the tree structure directly under the branch
you have clicked on. At the same time also a table will pop up in the table area, in which you can edit the
metadata of the new session node (e.g. session name, title, description, language etc.).

Remember that media files can only be added under Session nodes. For a more complete description on how
to add media files to sessions, see Section 4.7.
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Figure 4.2. Adding a new session node to a corpus branch

4.3.  Adding a new catalogue node
The catalogue node is generally meant to provide extensive information about the corpus and its sub-
branches (remember that the metadata window of a regular corpus node only contains three fields to begin
with). In this node you can insert various types of information about your (sub)corpora. It is available only
for the corpus nodes, NOT for the session nodes. An example of all the fields contained in a catalogue
is displayed below. It is highly advisable to create a catalogue for corpora! To add a new catalogue to a
corpus branch, right click a corpus node and select Add > Catalogue. A catalogue will be created in the
tree structure directly under the node.

Figure 4.3. Catalogue

Note

A corpus node can only have one catalogue. If you already have a catalogue and decide to
create a new one, your old one will be replaced by the new one.
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4.4. Adding other components
As shown above, you can add session nodes and catalogues to corpus nodes. Moreover, you can also add
additional elements to session nodes and catalogues. If you right click on a catalogue and select Add, you
will see a list of items available in the context menu. Notice how some elements have the  icon, whereas

others have a  icon. The  icon represents a component that will be displayed in the hierarchy, whereas

the  icon adds a new field (see section below).

Figure 4.4. Catalogue context menu

4.5. Adding more field components
Generally, every corpus, session, catalogue, contains a particular set of fields which can be edited. Adding

 elements implies adding a new metadata field to the selected node.

Figure 4.5. Standard field name

For example, the standard Field Name includes one field for author. You might want to add an additional
'author' field. To do this, right click on a catalogue and select Add > Author. Some fields can be added
multiple times, others can be added only once.
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Figure 4.6. Add new metadata field

4.6. Add field with custom name
Yu can also add a field with a custom name to a node in a session. Let's take an actor node as example. Right
click on the actor node name in the tree structure and select Add > Actor Key. The new field appears as
Keys.Key.Standard Template Key in the list of the field names in the metadata table. In order to change
the name of this new field right click on it and select Open in Long Field Editor. Once the editor has opened
select Change key name, modify the name and select Apply. Note that: 1) the new name will always start
with Keys.Key., which is there by default; 2) only key fields can have their name changed; 3) you can add
a field with a custom name (i.e. key option) only in Session, Content, Actor, Media File, Written Resource
and Source.§

If, after you have added and customized the new key field(s), you wish to use it for other nodes as well,
you can create a favourite for this node so that you can re-use it instead of repeating the whole process for
every new node.

4.7. Delete field(s)
Fields can also be deleted both for the metadata table of a single instance (see figure below), and from the
one containing several nodes. As far as one single instance is concerned, you have to open such instance in
the table area (either via right click > View selected, or simply by dragging and dropping the instance in the
main area). Then select the field you want to delete, right click it and select Delete 1 field(s) "...". Note that
mandatory fields are NOT deletable; in case of a mandatory field you will not be able to see the delete option.
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Figure 4.7. Delete field from single instance

In case of multiple instances in one single table (see figure below), what changes is the layout of the table
itself, but the deletion process is the same as the one explained above for single instances. Open the instances
in the table area, choose the field you want to delete, right click on it and select Delete field from all nodes.
Note that, as before, mandatory fields CANNOT be deleted. Unlike with single instances, though, here you
will always be able to see the delete option, the only difference being that in case of undeletable field a
message will pop out telling you that that specific field cannot be deleted from the nodes.

Figure 4.8. Delete field from several instances

4.8. Adding resource files to a session
There are two ways of adding resource files (e.g. audio, video etc.) to a session:

(1) The easiest way is to drag and drop a given element from the Working Directory to a session node in the
Local Corpus. All information about the resource (e.g. its size, type etc.) will be filled in automatically.
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(2) It is also possible to add it by right clicking on a session node in the Local Corpus and choose Add >
Media File or Add > Written Resource. In the latter case, however, you will have to fill in manually the
metadata of the file, its location, its media type, format and size in the window that will appear.

Note that not all file types are archivable. If a file is not archivable, you will not be able to drag and drop
it (any problem with the file will be illustrated by the  icon).

h

Figure 4.9. Adding a written resource by dragging and dropping

Figure 4.10. Adding a media file via the menu

It is also possible to manually add resources from a remote location, i.e. the archive or the web. This can
be done by right clicking on a node that supports a resource location (IMDI media file or written resource),
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selecting Insert Manual Resource Location, and adding the URL in the window that appears in the table
area.

Figure 4.11. Insert manual remote resources

When multiple resources are added from the Working Directories to a session in the Local Corpus, they will
get processed together and appear in a single table in the table area.

4.9. Copying and moving corpus and session
nodes

Arbil allows you to move both corpus and session nodes from one location to another. To do so, select in
your Local Corpus a corpus/session you would like to move and drag and drop it to the new location. It is
also possible to move the subnodes of a session, e.g. Actors, MediaFiles, WrittenResources, across sessions.

Note

Be aware that when you copy a corpus node (i.e. a node containing child nodes), Arbil does
not recognize it as a node but rather as a file. That means that the whole structure of subnodes
has not been copied properly (i.e. you will be able to see only the parent node). You will have
to add the child nodes one by one.

4.10. Deleting corpus elements
In order to delete corpus branches, sessions, or session components, right click on a chosen element and
select Delete. If you want to remove several elements at a time, choose them all while holding the Ctrl
(or Shift) button. Right click on the selected elements and chose Delete. In both cases (single or several
elements) you will have to confirm the deletion.

4.11. Saving changes
The changes to your files are not applied automatically. You have to save them yourself. To save the changes
made in your local corpus: 1) right click on the node and choose Save Changes to Disk; 2) from File menu
select Save Changes; 3) use the key short cut (i.e. Ctrl+S/cmd+S).
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Chapter 5. Editing the metadata

5.1. Editing one cell
To edit a corpus or session just click on it (A), or right click on it and choose View selected (B). In the window
that appears, click on the field you want to change. Type in the new value: typing in an existing cell will
start editing for replacing the existing content. Pressing the F2-key on Windows/Linux or the CTRL-U-key
on a Mac will start editing without removing content. Press Enter to go to the next value. If the value you
have typed is too long for the cell, the long field editor will open automatically in order to edit this value
(see section 5.2).

Figure 5.1. Editing

Some of the cells have either an open ( , ) or a closed ( , ) vocabulary (figure 5.2). In both
cases, when you double click the field you need, a drop-down menu will appear showing you available
default values.

In the case of open vocabulary fields, you are allowed to type your own value (if, for example, you would
like to have "grandfather" as a family role but you cannot find it in the list).

In closed vocabulary fields, by contrast, it is only possible to choose from the items of the list (e.g. sex:
male/female).

Notice that when you enter a value that is incorrect, the text will be shown in red; otherwise it will be in blue.

In the case of  (i.e. open vocabulary) you can add multiple values (either from the drop down, or your
own value) by inserting a comma (,) between the values.

In controlled vocabulary fields 'type-ahead' functionality is available (i.e. typing the first letter of the new
value will offer a suggested value from the drop down); to confirm a suggestion, press ENTER or type a
comma in multi-CV to add another value.
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Figure 5.2. Closed vocabularies

In some descriptive elements, you will also see a drop-down menu from which you can choose a language
which you use to describe the data information. To do so, click in the right corner of the field.

Figure 5.3. Choosing a language, click on desired language

5.2. Long field editor
The Long Field Editor (LFE) allows the user to edit long values, such as descriptions. The LFE works either
automatically or manually. If you want to add a long description in a cell you can right click on the field in
the table and select Open in Long Field Editor. In the window that appears you can add new text and/or
edit the already present text. If a field already contains a long value and you wish to edit it, double click
on it; the LFE will open automatically.

The LFE can be opened on a selected node by right clicking on it and selecting Edit in Long Field Editor.
The LFE opens on the first field under the node (generally the field Name), you can then navigate in the
fields by using the previous and next buttons (1). The field you are currently in appears on the top of the
LFE (2). The text appears and can be edited in the white area (3).

Changes made in the LFE get applied to the field as soon as the LFE is closed or by pressing the previous
or next buttons.
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Figure 5.4. Long Field Editor

5.3. Editing multiple cells
It will often be the case that a piece of information (e.g. continent, country, address etc.) has to be repeated
across the sessions. Instead of typing this data in every session, you can copy-paste it at once into all the
relevant fields. Choose the relevant sessions by holding Ctrl and clicking on them. Then right click on one
of the selected items and choose View selected. You will see a window appearing in which you can edit
the sessions.

To edit the selected sessions, take the following steps:

1. Fill one of the session fields (or choose a default value from the drop-down menu that you need, e.g.
Country). If one of these session fields is already filled in with the relevant information, skip this step.

2. Right click on one of the selected cell and select Copy.

3. Select the fields where you want to paste the copied information (one by one) by holding Ctrl and clicking
on them. Right click on one of the selected fields and chose Paste.

Figure 5.5. Pasting data into multiple cells

If you want to copy a value into all the cells of a certain column, select the field you want you copy, right
click it and chose Copy Cell to Whole Column. All the cells in the column will be changed accordingly.
Note, however, that this option is only applicable to one column at a time.
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Figure 5.6. Copying the value of a cell to all the cells of a column

It is also possible to copy-paste values to multiple columns simultaneously. To do so, while holding Ctrl (or
cmd), select the relevant cells of a metadata file, right click one of them and choose Copy.

Figure 5.7. Copying values from columns in one metadata file

Now choose the cells within the selected columns into which you want to paste the copied value by Ctrl (or
cmd) clicking on them (you can also draw a box over them with the cursor), right click one of the cells and
select Paste. The values will be pasted into the appropriate columns.

Note that you cannot copy-paste data from different rows, only from different columns.

Figure 5.8. Pasting values from two columns into several metadata files

It is possible to show the entire document containing any specific node that is shown in the horizontal table
view. To do so, right click a cell or row and select Show Context. This menu item opens the hierarchical
'sub-nodes' view on the root of the document that contains the selected cell or row.
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Figure 5.9. Show Context

5.3.1. Find and Replace

Another option in editing cells is the Find and Replace option activated by pressing, when you are in a table,
CTRL/CMD+F, or by right clicking on a cell and selecting the option Find/Replace. In both cases a line
appears at the bottom of the table with two boxes (figure below); the left box (marked in red) is used to define
the term you intend to find; the right box (marked in green) is used to define the term to be replaced with.
By pressing the Find Next key the term specified in the first box is highlighted in the table; now you can
either replace such term by pressing the Replace Selected key, or skip it and move to the next by pressing
Find Next. Once you have moved to the next term in the table, you cannot go to a previous term. In that case
you will have to manually select a previous cell to start from and continue searching.

Figure 5.10. Find and Replace

5.4. Editing All Metadata of a Subnode
It is also possible for the user of Arbil to get access to all the metadata under a node in a hierarchical order
(see figure below), so as to edit such metadata. To do so, right click on a session on the tree view and select
Edit all metadata (this function CANNOT be used on Corpus nodes). Editing can be done in all cells in
the way it has already been described.
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Figure 5.11. Edit/view all metadata

5.5. Customizing Column Views
When viewing/editing multiple elements in a table, sometimes there are many columns to go through. It is
possible to reduce them by choosing which columns you want to see or which columns you want to hide.
Right click the header of any column, i.e. Name, and select the option Edit this Column View. In the
window that pops up, you can select the columns that you want to show Show Only or hide Hide (if you
check only the Hide column, the unchecked field names will be shown in the table). It is important to know
that the column(s) which are hidden through this particular window, are not removed from the corpus itself.

Figure 5.12. Choosing columns

So let's say that you have Date and Description marked as Show only (see figure below). This means that
if you would now use this window to check out a node that has other categories than the ones selected with
the option Show only, then these categories will not be displayed. So the window in this particular example
will only have two columns.

If you have a table with: Name, Title and Description and you set the Description to Hide, it means that
Description will never be shown. But if the elements that you add to the window have other categories, these
will still be displayed and the number of columns will increase accordingly (assuming that you don't use
the show only option).

One more option of customizing the column view is the function Limit View to Current Columns, which
you will find by right clicking the header of a column. When chosen, this mode will freeze the current
columns view, meaning that no matter what element you add to the window, only the current categories
(columns) will be shown.

It is also possible to set the width of the columns by dragging the right or left edge of the column. This
applies to arbitrary open tables as well as saved column views.
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Figure 5.13. Editing column view

It is also possible to hide a column from the current view. To do so, right click on the column that you do
not want to be displayed and choose This column (...) > Hide Column.

Figure 5.14. Hiding one column

Note

The right click menu option This column (...) also serves to adjust the size of the columns.
Through the secondary options (see figure above) you can either make the column size fix
(Fixed column size) or to make the columns big enough in order for their content to fit (Make
column fit contents).

Once you have hidden the unnecessary columns, you can save this view by right clicking any of the headers
of the columns and choosing Save Current Column View. Give the column view a name and select OK.
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Figure 5.15. Saving Column View

Currently it is NOT possible to delete the column views that you create.

The view you have just saved is also applicable to other tables. Right click the header column of the new
Table, select Column View for this Table and choose the view you want. By default, there are two views
already defined and cannot be modified: All (i.e. all columns are displayed), and Minimal (i.e. only Name,
Title and Description are displayed). It is important not to forget that each view you create initially is window
specific. In this way you can use different views for different windows.

It is also possible to set your modified column view as the default column view that will appear in all tables
you open. To do so, go to Options menu in Arbil toolbar, select Column View For New Tables and the
preferred column view. This is now your default column view. (see number 1 in the figure below).

Figure 5.16. Setting new default column view

Note

Column views that have been modified and multiple open windows in the working area, either
saved or unsaved, are available after closing Arbil once the programme starts again exactly in
the same way they were before closing it provided the Save Windows on Exit is activated in
the Options menu (see number 2 in the figure above).

5.6. Highlighting cells with the same value
If you want to see which cells in a table have the same value, right click the appropriate cell and choose
Highlight Matching Cells. Cells with the same value will be highlighted. You can do this with more than
one cell; each new group of matching cells will be given a different colour. To remove the highlight, right
click on a cell and choose: Clear Cell Highlight.
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Figure 5.17. Highlighting cells

5.7. Track Table Selection in Tree
It may be the case that you have, in the main area of the application (i.e. the bottom right part in the figure
below) an open table with many elements displayed. Given this high amount of resources/sessions, you may
not be able to recognize which one you need, or else which is which. From the Options menu mark the
option Track Table Selection in Tree: now if you select an item in the table, its corresponding location on
the tree will be highlighted, thus enabling you to know which and where you required item is.

Figure 5.18. Track table Selection in Tree
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Chapter 6. Searching

6.1. Searching Local Corpus
The search option allows you to find a value throughout either the Local Corpus or the Remote Corpus (see
section 6.2 below). To do so, right click on a given node you want to search and select Search (you might
also choose a number of nodes by holding Ctrl and clicking on them). A window will appear in which you
can specify where and what exactly you want to search e.g. within Corpus, Session, Catalogue, Actor etc.

Figure 6.1. Selecting search locations

In the search window you can further specify in which column you want to search. By clicking on <column
(optional)> a drop down list appears, containing pre-defined common values and previously entered column
names; it is also possible to manually add column names to this list, or to remove arbitrary items by selecting
the value and pressing the delete key on your keyboard; deleted values have to be retyped and searched for
in order to appear in the drop down list again. After specifying the column (e.g. Name), give the value name
you look for, e.g. "Blance", and click on search.

By selecting either Equal ( ) or Unequal ( ), you will need to specify whether your search results
should match the word you filled in or rather show you where this word does not appear.

6.2. Searching Remote Corpus
In the first row of the remote search it is necessary to specify what you are looking for in the remote corpus
so that the search will be narrowed down within the remote corpus (see figure 6.2 below). The results based
on the first row provide all the nodes from all the sessions with this term (green box below). These results
can be reduced by specifying more values in the second search row (red box below). After specifying values
in the second line, searching in the remote corpus is similar to searching in the local corpus.
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Figure 6.2. Searching Remote Corpus

6.3. Display of Search Results
Suppose the search we are going to make is: Name (<column (optional)>) equals (==) Peter (<value
(optional)>). After clicking on search, the results will be displayed in a table such as the one below. In
case the content of one or more cell exactly matches the value you have searched for, the cell(s) will be
highlighted.

Figure 6.3. Display of Search Results
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Chapter 7. Exporting and Importing
data

7.1. Exporting data from Arbil
After creating new corpus branches or editing corpora from an already existing archive, you can save your
files and upload them to the appropriate archive. In order to do so you need to export your files from Arbil.
Select the modified nodes or the branch that contains the modified parts, right click on them and select
Export. A dialogue box will pop up, in which you choose the location of the export and the name of the
file. To complete the export, click on Export Branch Destination Directory.

Figure 7.1. Exporting files

The following message will appear:

Figure 7.2. Export alert message

Selecting OK will lead you to a message window which is the same as the one seen above regarding the
import into the Local Corpus (see Figure 7.3).
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Figure 7.3. Export data

7.1.1. More export options

The export window offers advanced export options. These can be accessed by clicking the button More
options (see Figure 7.4).

Figure 7.4. Export window - more options

The following options are available:

• Convert exported IMDI to CMDI: This option converts the exported IMDI files to the CMDI file type.
This gives you the possibility to import the exported files to a CMDI archive.

• Rename Metadata Files : Rename files to match local corpus tree names.

• Limit Characters in File Names: This replaces all characters in the filenames which are not accepted
by LAMUS. Currently accepted are digits, non-accented letters, dots (.), underscores (_) and hyphens (-).
All other characters will be replaced.

7.1.2. Export process details

By selecting Details you can inspect the export process details including possible erros (see Figure 7.5).
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Figure 7.5. Export window - details

7.2. Importing data into Arbil
In Arbil there is a number of possibilities to import the data.

The first way to import data is from the Remote corpus to the Local corpus, either by right clicking on the
required branch in the remote corpus and selecting Import to Local Corpus, or by dragging and dropping it.

If you want to import data from you local computer disk, or from the network, go to File menu, select
Import, and then choose the required data from your local disk, or from the network; your data wil be
imported at the root level.

In addition, at Local Corpus level, the context menu that comes out when right clicking one of the nodes
includes further import options:

Import Branch (i.e. importing a piece of your corpus) gives you the ability to import part of your corpus
from your disk to the Local corpus.

Reimport this branch (i.e. re-importing form the remote corpus): in order to make changes to a corpus you
have already exported to the Remote corpus via Lamus, it is essential to reimport such corpus to the Local
corpus and choose Yes to the message question "Overwrite?".

Import CSV (i.e. in the table format) gives you the ability to import edited data in the Local corpus in the
form of a table (for details see section 7.3 below).
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7.3. Using an External Editor
As we have already noted, it is possible to open, view and modify the data using external editors such as
spread sheets or text editors. Overall the process is done by moving data from Arbil to the external editor,
making the necessary changes, and then moving them back to Arbil.

However, possibilities of moving data back into Arbil are currently very limited. It is possible to do any
of the following:

• Copy single field values (individual cells) from the external editor into Arbil;

• In case of the IMDI Session root node, save your data in CSV format, and then import them to Arbil by
right clicking on the node where you want to copy them back and selecting Import CSV. This way you
will be able to import the data in a table format; in any other case you will have to import the edited data
column by column, but not all at once;

• If cells in a table corresponding to a single metadata file are copied, then the data will be in a format that
can then be pasted back into any table in Arbil, provided that the data maintains the same formatting.

The following functions are currently not available:

• Pasting of multiple rows (i.e. data representing multiple nodes) into Arbil, even if the table in Arbil has
an identical structure;

• Pasting of multiple values in general unless their structure corresponds to one of the options listed above;

• Importing CSV to any other type of node than the Session root.

To open the data in an external editor (i.e. Ms Excel), select and copy the data from the table, then paste
them in the editor you wish to use.

Figure 7.6. Editing data in an External editor

7.4. External application
By selecting Open in External Application you can view, and edit, resourses and metadata in the
application that your computer chooses by default, such as a media player for a video file, or a text editor
for a text file.
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Figure 7.7. Viewing data in external application
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Chapter 8. Exiting Arbil
Before exiting Arbil make sure that you have saved all your changes. This can easily be done by the key
short-cut CTRL+S.

You can exit Arbil by closing the main window, or through File > Exit on Wi§ndows or Linux, or Arbil
> Quit Arbil on Mac OS.

In case of unsaved changes a message will appear and ask if you wish to "Save changes before exiting";
choose "yes" or "no"; Arbil is now closed.
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Chapter 9. Shortcut Keys
In Arbil you can use the following shortcuts:

Table 9.1. General shortcut keys

CTRL/CMD+A Select all

CTRL/CMD+F Find & Replace

CTRL/CMD+S Save

CTRL/CMD+W Close topmost window

CTRL/CMD+SHIFT+W Close all windows

CTRL+TAB Next window

CTRL/CMD+SHIFT+TAB Previous window

CTRL+P/CMD+P Hide/Show the selection preview

CTRL++/CMD++ Increase the font size used in the application

CTRL+-/CMD+- Decrease the font size used in the application

CTRL+0/CMD+0 Reset the font size used in the application to the
default value

ENTER (in the tree) Open the current tree selection in a table

DELETE (in the tree) Delete the selected node from the tree

Table 9.2. Table short cut keys

CTRL/CMD+A Select all

CTRL/CMD+C Copy

CTRL/CMD+V Paste

CTRL/CMD+Z Undo

DELETE Delete the contents of the current table cell and start
editing

ESC Cancel editing of the current cell

CTRL+ENTER Edit a cell in a new window

Table 9.3. Tree short cut keys

DELETE Delete the selected node in the tree

Table 9.4. Long field editor short cut keys

CTRL+UP Go to previous field

CTRL+DOWN Go the next field

CTRL+LEFT Go to previous tab

CTRL+RIGHT Go to next tab
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Chapter 10. Technical details
10.1. Custom Filetypes Configuration

It is possible to override the default set of filetypes that the type checker should recognize as archivable
resources.

To do so, place your custom filetypes.txt configuration file at the root of your local storage directory (to find
out what that is, select Local Corpus Storage Directory from the Options menu). It will then automatically
be installed in the type checker as soon as type checking takes place for the first time during a session. You
will need to restart Arbil if it is already running.

If you have already typechecked files within your working directories when you replace the configuration,
Arbil will still remember the old status for these files. To make Arbil forget about this, you can delete the
following three files from the root of your local storage directory:

• knownMimeTypesV2

• md5SumToDuplicates

• pathToMd5Sums

Arbil will now recheck every file within its working directories, so depending on how much is in there, this
might take some time.

For information about obtaining or creating a custom filetypes configuration, please contact your
administrator.

10.2. Templates
Templates are currently in development, but they will be used to customise the components added via the
"Add" menu.

To create a new template, create a directory in the ".arbil/templates" directory. This is where all the files
relevant to that template will be stored. This directory will now be selectable via the "options/templates"
menu.

Each template can have its own XSL which is used via the "view formatted" menu. The XSL must be in
the selected templates directory and be called "format.xsl". For example: .arbil/templates/{template name}/
format.xsl. If there are any additional files required by the XSL they can be placed in the same directory
as the XSL file.

10.3. New languages
More languages can be added to the MPI-Languages CV upon request. Send an e-mail to
corpus.manager@mpi.nl with the name and the ISO 639-3 code of the language you want to add.

10.4. Plugins
Plugins add extra functionality to Arbil. They are provided as '.jar' files that can be placed in a special
location where Arbil will detect them and add them as items to the 'Plugins' menu (which is hidden unless
plugins have actually been detected).

To install a plugin, place the .jar file in one of the following directories:

• ~/ArchivingPlugins (Linux or MacOS)
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• %APPDATA%/ArchivingPlugins (Windows)

• %USERPROFILE%/ArchivingPlugins (Windows)

• <ARBIL STORAGE DIRECTORY>/ArchivingPlugins

If none of the locations already exist, you can create one. Some options will not be available on all operating
systems. ~ denotes the user's home directory on Unix systems. %APPDATA% and %USERPROFILE%
are system environments available in Windows. Use the 'run command' option (Windows key + R) to open
locations that contain the environment variable.

<ARBIL STORAGE DIRECTORY> is the directory called .arbil that contains the configuration files and
by default is the parent directory of the working files directory.

After installing the plugin you should restart Arbil for it to become available in the Plugins menu of the
menu bar.

10.5. Custom logging configuration
If present, a logging configuration will be read and applied from a file called 'logging.properties' in the
application configuration directory ('.arbil'). An example of such a configuration is given below.

The logging output (visible in the log console of the Help menu) can be observed from different levels of
detail. Such levels are: ALL, FINE, INFO, WARNING, SEVERE. Note that the log console is visible
only when the application is installed, i.e. NOT with the webstart version.

        handlers= java.util.logging.FileHandler, java.util.logging.ConsoleHandler
        
        # Default global logging level.
        .level = ALL
        
        ############################################################
        # Handler specific properties.
        # Describes specific configuration info for Handlers.
        ############################################################
        
        # default file output is in user's home directory.
        java.util.logging.FileHandler.pattern = %h/arbil.log
        java.util.logging.FileHandler.level = WARNING
        java.util.logging.FileHandler.formatter = java.util.logging.SimpleFormatter
        
        # Limit the message that are printed on the console to INFO and above.
        java.util.logging.ConsoleHandler.level = FINE
        java.util.logging.ConsoleHandler.formatter = java.util.logging.SimpleFormatter
        
        
        ############################################################
        # Facility specific properties.
        ############################################################
        
        java.level = WARNING
        javax.level = WARNING
        sun.level = WARNING
        
        nl.mpi.arbil.level = FINEST
        nl.mpi.flap.level = FINEST
        nl.mpi.level = FINEST
      


